[tk] Egg Avatar

Discussion in 'vB 3.8.X Addons and Template Modifications' started by MobileHacks, Mar 14, 2009.

  1. MobileHacks

    MobileHacks New Member

    Updated To Version:2.3.1
    Fixed bug in vB Optimise integration.
     
  2. Calystos

    Calystos New Member

    Not sure why but I just updated to 2.3.1, an now when its enabled I can't see avatars at all, but with 2.2.2 I had no problems.

    Anyone have any ideas?
     
  3. bulletin

    bulletin New Member

    Did you uninstall the old product and re-installed the newest version of product? If yes, then there shouldn't be any problem, hope you have installed all files in the correct folder?
     
  4. MobileHacks

    MobileHacks New Member

    Make sure you Unzip and upload all files in the upload directory to your forum root.Over Writing old Files
    Then
    Import the product file in your admincp - make sure Allow Overwrite is set to 'yes'.

     
  5. Calystos

    Calystos New Member

    I'll re-install the old one, an upgrade again an see what happens. I've done the upgrade way for all previous versions without problems. And I always upload the entire upload area to the site, :)

    EDIT: Downgraded back to 2.2.1 an its working fine. Now gonna try to re-upgrade again.
     
  6. Mr-Ice-Man

    Mr-Ice-Man New Member

    With this new version when i have the egged mod enabled to show in whats going on i get a error on the whole forum saying >>>

    Warning: main([path]/includes/class_activecache.php) [function.main]: failed to open stream: No such file or directory in [path]/plugins/eggavatar_forumhome_complete.php on line 6

    Fatal error: main() [function.require]: Failed opening required '/home/sites/***.org/public_html/forum/includes/class_activecache.php' (include_path='.:/usr/share/pear') in /home/sites/***.org/public_html/forum/plugins/eggavatar_forumhome_complete.php on line 6


    And none of the avatars show at all.
     
  7. Calystos

    Calystos New Member

    Yup, I downgraded back to 2.2.2 an it worked great. I uploaded all latest files then upgraded as usual an no avatars. Gonna try downgrading back an upload to the previous build before latest an see if that works or not.

    EDIT: K, seems to be something in the 2.3.1 files. I TOTALLY uninstalled the mod (erased ALL the files from v2.2.2 and 2.3.1) an my site was fine. I uploaded the files from 2.3.1 an reloaded a page to see (without installing the product yet) an no avatar at all shows up. I installed the mod, an still no avatars.

    I did the exact same thing with 2.2.2, first wiped all of 2.3.1. Uploaded all the files, an refreshed/reloaded a test page an avatars there fine. I installed the product, avatars still there.

    Looks like 2.3.1 hates my site atm. Gonna do a few more checks an see if I can figure out why. :)
     
  8. bulletin

    bulletin New Member

    ok looking at your problem what i can see is either you do not have vbulletin 3.8.1 version on your site or else you have messed up with old and new files of eggavatar. I am using 3.8.1 version and for test basis i have installed more than 200 mods on my test site, where i didnt found any such bugs or issues with egg avatar 2.3.1. I am sure you are doing something wrong while uploading files. Re-Check all files that you have uploaded on your server and next check usergroup permission, later check if you have vbcredits, vboptimise are installed on your site. If you do not have those both mods installed on your site, then do not click on yes for vbcredits and vboptimise, and another thing see that you have uploaded images in misc/eggs and give 777 permission to eggs folder, if you want to upload your own eggs images. I think this should help you to get sorted out with your issues. However if you do have screenshot of your egg avatar, then it would be much easier to help you.
     
  9. Calystos

    Calystos New Member

    I'm running 3.8.1, and up til now have never had any problems. I too have installed hundreds of mods, an tweaked my site loads.

    The only thing I can think of is another mod I just recently added is screwing things up. vB Optimise 1.3.2. An I ran the options to speed up the site an stuff. So I'm thinking its messing up, cos one of the things it wanted me to do was move the avatars/etc from the database to files. Which I did. An I think this is whats messed up my site.

    Gonna see about removing it an see what happens.

    EDIT: K, got it re-installed, but soon as I go to the usergroup options and set it to view then the avatars stop showing up. The splat to open the avatars egging works. But neither the avatar nor an egged avatar appears.

    EDIT: The "Can egg other avatars" and "Can clean own avatars" options are the ones that are screwing me over. Soon as either of those two options are enabled the avatars stop appearing. Also even with the "Can clean other's avatars" option enabled the paint splat thing doesn't seem to show up on the postbit in threads to clean other peoples avatars. But the new stats system works fine. And even though I've egged an avatar its not showing up as egged even though the "Can view egged avatars" is enabled. *shrugs*
     
  10. bulletin

    bulletin New Member

    Cant understand your problem, though screenshot is most easier way to help you, so if you can take screenshot of those bugs and show how avatar is not working, it will be much easier to help you.
     
  11. Calystos

    Calystos New Member

    Nothing much to screenshot, it just shows as text instead of any actual avatar. But thats only if either of those two options are enabled.

    EG for me it shows "Calystos's Avatar". Or for anyone else its their name of course. Without those two options enabled the avatars show up fine. Not sure why, gonna do some checks on the code and the database an other files involved on my test server an see if theres anything I can see that may be to blame. As I said the only things I added other than this update was the cache system vb optimiser. Then did its tweaking to move avatars and other things from being in the database to being in hardfiles. But on my test server I've not installed any of them yet so will see if its to blame somehow.

    EDIT: Yup, I installed without any problems on the test server that didn't have the vb optimiser cache installed. So somethings up there with mine I think. Might try wiping an reinstalling it an see if that works.
     
  12. MobileHacks

    MobileHacks New Member

    Updated To Version:2.3.2
    Fixed bug if paths to avatars has a leading '/'.
     
  13. Mr-Ice-Man

    Mr-Ice-Man New Member

    Still doesnt work the avatars still show as blank
     
  14. iluminati

    iluminati New Member

    it used to happen the same thing to me, but i disable the integration with vb optimize and the avatar start to work fine again
     
  15. Calystos

    Calystos New Member

    Turned out that in my case the avatars weren't showing up cos of a problem with the hosts imagemagick system is possibly not installed right or something. I set my site back to using GD an the avatars are showing up again. But now the paint splat thing isn't, lol. So even though avatars are showing up we can't throw eggs or anything cos the button to do it isn't showing up, fdlol. Ahh fun times...

    I figured out it was imagemagick to blame before when I tried going to a direct image link via the properties of an avatar. An it came out with the following errors:
    Which I fixed when I went into class_eggavatar_image.php an changed the "$tmpfname = tempnam("", 'tk_');" to read "$tmpfname = tempnam("/tmp", 'tk_');" which is what the other line that tempnam was at read as (the "/tmp" bit). But again the splat mark to egg people didn't show up.

    Yup, if I add that "/tmp" bit an re-try the same test direct URL to the avatar egg thing it comes up with the same PNG info as the GD system does. So the avatars are showing up right an whatnot.

    So whether or not I'm set to use GD or ImageMagick it doesn't matter. The avatars are showing up fine now at least, but the icon to egg people isn't. Well least narrowing things down, :-D

    EDIT: Turned out it was cos of the mod "WarLion Online/Offline" option to disable the user online/offline icon. Since the egg mod is looking for that code. I enabled it an it worked fine an everythings back up an running in ImageMagick mode, :-D And with vb optimize mode enabled too.

    So anyone who uses their forum in ImageMagick mode for images try editing the "includes/class_eggavatar_image.php" file and going to line 187 (this is in v2.3.2 of the mod btw!) an just doing that change I mentioned earlier. "$tmpfname = tempnam("", 'tk_');" to read "$tmpfname = tempnam("/tmp", 'tk_');" An that should fix things for you too.
     
  16. MobileHacks

    MobileHacks New Member

    Updated To Version:2.3.3
     
  17. MobileHacks

    MobileHacks New Member

    Updated To Version:2.3.4
    2.3.4 Fixes a "can't view if can't egg" permissions problem that has been plaguing some users. Adds a vbAdvanced Module.
     
  18. xblade_2k9

    xblade_2k9 New Member

    this script is a true shit, using this mod server cpu average is 108%, delete this script, no is safe for hostings
     
  19. bulletin

    bulletin New Member

    lol are you kidding? how can it reach to 108% of cpu usage? when server cpu can only have 100% usage, you are making me laugh with your this statement, anyways i am using this mod too, and didnt had any trouble on shared hosting due to this mod.
     
  20. xblade_2k9

    xblade_2k9 New Member

    is a comment man, you use this :) and you website any day you can read, SUSPENDED.
     

Share This Page