[function.move-uploaded-file]

Discussion in 'Server Management' started by cicciociccio, Mar 17, 2013.

  1. cicciociccio

    cicciociccio New Member

    Hey Guys
    Today i updated the dns records ie made my own nameservers from ip my as webmail was not working in kloxo and after doing that it was working fine and i was just checking stuff in kloxo dont know what i did but then i went to sleep and when i woke up the images on my site were not uploading it was giving a Sorry, there was a problem uploading your file error.
    So i changed back the dns settings ie deleted the nameservers i created and got the domain back to the host in (Ofc i had my A records already added)
    So still then nothing happened same error so i went in the php settings and enabled display errors in that it said

    Quote: Notice: Undefined variable: numbers in /home/admin/imgrill/upload.php on line 61
    Image 1

    Warning: move_uploaded_file(upload/big/2013/02/17/5120f3e81e5b3.png) [function.move-uploaded-file]: failed to open stream: Permission denied in /home/admin/imgrill/inc/functions.php on line 794

    Warning: move_uploaded_file() [function.move-uploaded-file]: Unable to move '/tmp/phpXOwZyu' to 'upload/big/2013/02/17/5120f3e81e5b3.png' in /home/admin/imgrill/inc/functions.php on line 794 and then i uploaded the script on another domain but on the same server and still facing same problem there [​IMG] so i guess it isnt a dns problem

    Note the permission for the upload directly are already 777 so what the devil is causing this
    It would be great if someone could help me out here
    Thanks

    ---------- Post added at 08:50 PM ---------- Previous post was at 08:17 PM ----------

    Damit [​IMG] it was a permission issue but no idea why it caused it like all the folders that are automatically made in the uploads folder work fine so i with the help of imgwoot started to chmod every folder one by one and the script also creates folders daily so i chmod the last folder ie todays folder and it worked fine
    But lets see what happens tomorrow if the problem starts again or not but i am confused on one thing why the devil did this problem arise it was working fine everyday I ran into the same problem was working fine then started getting permission errors my fix was to just chmod the dir after its created.
    Code: if (!is_dir('covers/'.$db_movie_id)) { mkdir('covers/'.$db_movie_id); chmod('covers/'.$db_movie_id, 0777);}if (!file_exists($path)) { file_put_contents($path, file_get_contents($url));}I no longer get any errors all images are moved without a problem. Why don't you use suphp and permission level 755 Check the owner/group for the folder upload and it's sub folders. Make sure they are accessible by the account running the script.
     

Share This Page